<!DOCTYPE html>
<html class="root root_js_disabled" lang="en-US" data-version="2.6.2.1" data-platform="desktop">
<head>
    <meta charset="utf-8" />
    <title>Video from Selena&#x27;s Houston Rodeo performance on Feb. 26, 1995 | khou.com</title>
    <script>!function(){window.performance.mark("tegna_server_response");var n=new URLSearchParams(window.location.search).get("otConsentString");if(n){document.cookie=`OptanonAlertBoxClosed=${(new Date).toISOString()}`;let e=new Date;e.setYear(e.getFullYear()+1),e=e.toISOString();var t=(new Date).toString().replace(/\ /g,"+").replace(/:/g,"%3A");document.cookie=`OptanonConsent=datestamp=${t}&version=6.0.0&interactionCount=0&isIABGlobal=false&landingPath=NotLandingPage&groups=${encodeURIComponent(n)}&hosts=&legInt=; expires=${e}`}}(),window.tegna=window.tegna||{},window.tegna.supportsJavascript="noModule"in document.createElement("script"),window.tegna.supportsJavascript?(document.documentElement.classList.remove("root_js_disabled"),window.tegna.performance={received:{time:window.performance.now()}},window.tegna.ie=!!window.MSInputMethodContext&&!!document.documentMode):document.documentElement.classList.add("root_ie_true");
//# sourceMappingURL=immediate.js.map</script>
    <style>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</style>
    <style>:root {
    --theme-primary: #045ea8;
    --theme-secondary: #045ea8;
}</style>

<link rel="preload" href="/modules.min_6.2.1.css" as="style" onload="this.onload=null;this.rel='stylesheet';window.tegna.performance.painted = { 'time': window.performance.now() };window.performance.mark('tegna_styled');" />
<noscript><link rel="stylesheet" href="/modules.min_6.2.1.css"></noscript>

<link rel="preload" href="/common.min_6.2.1.js" as="script" type="text/javascript" />

    <link rel="preconnect" href="//media.wbir.com">
    <link rel="preconnect" href="//interactive.wbir.com">
    <link rel="preconnect" href="//tgna-ux-dev.service.signalr.net">
    <link rel="preconnect" href="//securepubads.g.doubleclick.net">
    <link rel="preconnect" href="//www.google.com">
    <link rel="preconnect" href="//adservice.google.com">
    <link rel="preconnect" href="//tpc.googlesyndication.com">
    <link rel="preconnect" href="//cdn.ampproject.org">
    <link rel="preconnect" href="//pagead2.googlesyndication.com">
    <link rel="preconnect" href="//www.gstatic.com">
    <link rel="icon" href="/assets/favicons/KHOU.png?ver=2.6.2.1" />
    <link rel="canonical" href="https://www.khou.com/article/news/local/selena-rodeo-houston-video/285-5a155c18-d5a3-4921-afd7-1f8a831536d2" />
            <meta name="theme-color" content="#045ea8" />
            <link rel="amphtml" href="https://www.khou.com/amp/article/news/local/selena-rodeo-houston-video/285-5a155c18-d5a3-4921-afd7-1f8a831536d2" />
        <meta itemprop="datePublished" content="3:35 PM CST February 26, 2022" />
        <meta itemprop="dateModified" content="3:35 PM CST February 26, 2022" />
        <meta itemprop="url" content="https://www.khou.com/article/news/local/selena-rodeo-houston-video/285-5a155c18-d5a3-4921-afd7-1f8a831536d2" />
        <meta itemprop="magnet:custom" name="category" content="news" />
        <meta property="og:url" content="https://www.khou.com/article/news/local/selena-rodeo-houston-video/285-5a155c18-d5a3-4921-afd7-1f8a831536d2">
        <meta property="og:title" content="Video: Selena performed at Houston Rodeo on this date 27 years ago">
        <meta property="og:description" content="Just a month after this performance, the artist was shot and killed.">
        <meta property="og:type" content="article" />
        <meta property="og:image" content="https://media.khou.com/assets/KHOU/images/1df667b5-4a11-4b87-9e0c-56f446039b35/1df667b5-4a11-4b87-9e0c-56f446039b35_1140x641.jpg">
        <meta property="og:image:width" content="1140" />
        <meta property="og:image:height" content="641" />
        <meta property="og:article:published_time" content="3:35 PM CST February 26, 2022" />
        <meta property="article:opinion" content="false" />
        <meta property="article:content_tier" content="free">
        <meta property="article:section" content="khou,news,local,entertainment,rodeohouston" />
        <meta name="twitter:title" content="Video: Selena performed at Houston Rodeo on this date 27 years ago">
        <meta name="twitter:image:src" content="https://media.khou.com/assets/KHOU/images/1df667b5-4a11-4b87-9e0c-56f446039b35/1df667b5-4a11-4b87-9e0c-56f446039b35_1140x641.jpg">
        <meta name="twitter:image" content="https://media.khou.com/assets/KHOU/images/1df667b5-4a11-4b87-9e0c-56f446039b35/1df667b5-4a11-4b87-9e0c-56f446039b35_1140x641.jpg">
        <meta name="twitter:card" content="summary_large_image">
        <meta name="twitter:site" content="KHOU">
        <meta name="twitter:description" content="Just a month after this performance, the artist was shot and killed.">
        <meta name="twitter:domain" content="www.khou.com">


            <meta name="viewport" content="width=1170" />
            <meta name="site" content="khou.com" />
            <meta name="description" content="The Houston Livestock Show and Rodeo performance would be the last major concert for the megastar, just a month before she was shot and killed." />
            <meta property="fb:app_id" content="1981419195445082" />
            <meta property="og:site_name" content="khou.com" />
            <meta property="og:locale" content="en_US" />
            <meta itemprop="pageType" content="article" />
            <meta itemprop="datePublished" content="3:35 PM CST February 26, 2022" />
    <script>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</script>
        <!-- OneTrust Cookies Consent Notice start -->
        <script src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" type="text/javascript" charset="UTF-8" data-domain-script="6aa47faf-5e9e-4448-a991-4c8039587296"></script>
        <script type="text/javascript">function OptanonWrapper() { }</script>
        <!-- OneTrust Cookies Consent Notice end -->
        <script src="https://cdn.cookielaw.org/opt-out/otCCPAiab.js" type="text/javascript" charset="UTF-8" ccpa-opt-out-ids="C0004,C0002" ccpa-opt-out-geo="all" ccpa-opt-out-lspa="true"></script>
<!-- utag_data -->
<script id="utag_data_script" data-visit-event-name="pageView" data-current-site-id="285" data-watson-keywords="Tejano star Selena Quintanilla-P&#xE9;rez,big artists,Editor&#x27;s note,last major performance,coverage of Selena Last year" data-page-type="article" data-gpt-network-code="32805352/tx-houston-KHOU-B3351_DesktopTablet" data-section="news" data-subsection="local" data-topic="" data-subtopic="" data-content-type="article" data-category="news" data-market="Houston, TX" data-subcategory="local" data-keywords="KHOU, Houston, TX, news, local news, breaking news, traffic, weather, sports, events" data-document-title="Houston&#x27;s Leading Local News: Weather, Traffic, Sports and more | Houston, Texas | KHOU.com" data-ga-property-id="UA-74928651-1" data-division="broadcast" data-site-type="desktop" data-page-url="https://www.khou.com/article/news/local/selena-rodeo-houston-video/285-5a155c18-d5a3-4921-afd7-1f8a831536d2" data-canonical-url="https://www.khou.com/article/news/local/selena-rodeo-houston-video/285-5a155c18-d5a3-4921-afd7-1f8a831536d2" data-asset-id="5a155c18-d5a3-4921-afd7-1f8a831536d2" data-article-keywords="local,entertainment,rodeohouston,news" data-content-title="Video: Selena performed at Houston Rodeo on this date 27 years ago" data-content-categories="local,entertainment,rodeohouston,news" data-content-score="75" data-tracking-tags="" data-t1-publisher="rklein@tegna.com" data-call-letters="KHOU" data-article-byline="KHOU 11 Staff" data-topics-included="false" data-video-included="true" data-video-autoplay="true" data-video-title="Video: Selena performed at Houston Rodeo on this date 27 years ago" data-video-name="Video: Selena performed at Houston Rodeo on this date 27 years ago" data-video-length="0" data-video-related-play="false" data-item-number="1" data-original-headline="Video: Selena performed at Houston Rodeo on this date 27 years ago" data-cct-story="false" data-platform="desktop" data-full-environment="KHOU" data-index-wrapper-url="//js-sec.indexww.com/ht/p/184603-276362164742345.js" data-a9-publisher-id="3276" data-a9-timeout="1000" data-pubmatic-desktop-url="https://ads.pubmatic.com/AdServer/js/pwt/160138/3938/pwt.js" data-pubmatic-mobile-url="https://ads.pubmatic.com/AdServer/js/pwt/160138/3939/pwt.js">!function(){var e;window.tegna.supportsJavascript&&(e=document.getElementById("utag_data_script").dataset,window.tegna.initialTracking={visit_event_name:e.visitEventName,current_site_id:e.currentSiteId,watson_keywords:e.watsonKeywords,template_type:"",page_type:e.pageType,division:e.division,site_type:e.siteType,page_url:e.pageUrl,gpt_network_code:e.gptNetworkCode,section:e.section,subsection:e.subsection,topic:e.topic,subtopic:e.subtopic,content_type:e.contentType,category:e.category,market:e.market,subcategory:e.subcategory,keywords:e.keywords,document_title:e.documentTitle,ga_property_id:e.gaPropertyId,canonical_url:e.canonicalUrl,video_included:e.videoIncluded,video_name:e.videoName,video_length:e.videoLength,video_related_play:e.videoRelatedPlay,article_date:e.articleDate,asset_id:e.assetId,article_keywords:e.articleKeywords,content_title:e.contentTitle,original_headline:e.originalHeadline,content_categories:e.contentCategories,tracking_tags:e.trackingTags,t1_publisher:e.t1Publisher,article_byline:e.articleByline,topics_included:e.topicsIncluded,call_letters:e.callLetters,item_number:e.itemNumber,content_score:e.contentScore,cct_story:e.cctStory,platform:e.platform,full_environment:e.fullEnvironment,index_wrapper_url:e.indexWrapperUrl,a9_publisher_id:e.a9PublisherId,a9_timeout:e.a9Timeout,pubmatic_desktop_url:e.pubmaticDesktopUrl,pubmatic_mobile_url:e.pubmaticMobileUrl},window.utag_data=JSON.parse(JSON.stringify(window.tegna.initialTracking)))}();
//# sourceMappingURL=utag-data.js.map</script>
        <script src="https://www.google.com/recaptcha/api.js?onload=recaptchaCallback&render=explicit" async defer></script>
        <script type="text/javascript">var recaptchaCallback = function () {
                window.grecaptcha = grecaptcha;
                console.log('recaptcha is ready');
            }</script>
    <style>
        .root_ie_true template {
            display: none;
        }
        #onetrust-consent-sdk #onetrust-pc-sdk .pc-header {
            position: relative;
        }
        #onetrust-consent-sdk #onetrust-pc-sdk .pc-logo {
            background-image: url('/assets/shared-images/logos/khou.png') !important;
        }
    </style>
    <script type="text/javascript" data-taboola-type="article">window._taboola = window._taboola || [];
        let obj = {};
        obj[document.currentScript.dataset.taboolaType] = 'auto';
        _taboola.push(obj);</script>
    <!-- head content below this is dynamically added -->
</head>
<body>
    <script>if(window.tegna.supportsJavascript){window.tegna.addScript=e=>{var t=document.createElement("script");t.src=e,document.head.appendChild(t)},window.tegna.log=function(e,t,i,n){var o=(o=20-e.length)<0?0:o,a=(a=30-t.length)<0?0:a,r="log";"error"in console&&3===n?r="error":"warn"in console&&2===n?r="warn":"info"in console&&(r="info");a="["+e+"] "+" ".repeat(o)+t+" ".repeat(a);i?void 0:void 0},window.tegna.loadModule=function(e,i){var n=e.parentNode,o=n.querySelectorAll(".grid__template")[0];"undefined"!=typeof templatePolyfill&&templatePolyfill(n);var a=document.importNode(o.content,!0),t="IntersectionObserver"in window&&"IntersectionObserverEntry"in window;e.remove(),t?new window.IntersectionObserver(function(e,t){e.forEach(function(e){if(e.isIntersecting){o.remove(),n.append(a),n.closest(".grid__module").classList.add("grid__module_loaded_true"),n.closest(".grid__module").classList.remove("grid__module_loaded_false"),t.unobserve(n),"undefined"!=typeof require&&require([i]),"$"in window&&$(window).trigger("tegnaBroadcast",["grid","addedSection",{$el:$(n),el:n}]);let e={el:n};"$"in window&&(e.$el=$(n)),window.dispatchEvent(new CustomEvent("tegnaBroadcastNoJQ",{detail:{source:"grid",action:"addedSection",data:e}}))}})}).observe(n):(o.remove(),n.append(a))};class e extends HTMLElement{get os(){return this.getAttribute("os")}set os(e){this.setAttribute("os",e)}set active(e){e?(this.setAttribute("aria-hidden","false"),this.setAttribute("active","")):(this.setAttribute("aria-hidden","true"),this.removeAttribute("active"))}constructor(){super()}connectedCallback(){var e=navigator.userAgent||navigator.vendor||window.opera;let t="unknown";/android/i.test(e)&&(t="android"),/iPad|iPhone|iPod/.test(e)&&!window.MSStream&&(t="ios"),t===this.os.toLowerCase()?this.active=!0:this.active=!1}}window.customElements.define("tegna-sniff",e);class t extends HTMLElement{get uuid(){return this.getAttribute("uuid")}set uuid(e){this.setAttribute("uuid",e)}set active(e){e?(this.setAttribute("aria-hidden","false"),this.setAttribute("active","")):(this.setAttribute("aria-hidden","true"),this.removeAttribute("active"))}constructor(){super()}}window.customElements.define("tegna-variant",t);class i extends HTMLElement{get uuid(){return this.getAttribute("uuid")}set uuid(e){this.setAttribute("uuid",e)}constructor(){super()}connectedCallback(){window.setTimeout(()=>{let t=[...this.children],a=t[0].uuid;var e=window.localStorage.getItem(this.uuid);null!==e?(a=e,window.tegna.log("_abtest","showingStoredVariant",{test:this.uuid,variant:e})):(a=t[e=t.length,Math.floor(Math.random()*Math.floor(e))].uuid,window.localStorage.setItem(this.uuid,a),window.localStorage.setItem(`${this.uuid}_tegna_expire`,Date.now()+108e5),window.tegna.log("_abtest","showingNewVariant",{test:this.uuid,variant:a}));const i=async(e,t,i)=>{var n=document.querySelector(".page").dataset.uxTrackingUrl;const o=await fetch(n,{method:"POST",headers:{"Content-Type":"application/json",pragma:"no-cache","cache-control":"no-cache"},body:JSON.stringify({testId:this.uuid,siteId:document.querySelector(".page").dataset.siteId,variantId:a,click:e?1:0,impression:t?1:0})});o.text().then(e=>{i(e)})};for(var n=0;n<t.length;n++)if(t[n].uuid===a){t[n].active=!0,[...t[n].querySelectorAll("a:not([data-ab-click-mode=ignore])")].forEach((t,e)=>{t.addEventListener("click",e=>{e.preventDefault(),e.stopPropagation(),i(!0,!1,()=>{window.location=t.getAttribute("href")}),window.setTimeout(()=>{window.location=t.getAttribute("href")},500)})});let e=new IntersectionObserver((e,t)=>{e.forEach(e=>{e.isIntersecting?(window.tegna.log("_abtest","attemptingImpression",{el:this,test:this.uuid,variant:a}),i(!1,!0,()=>{window.tegna.log("_abtest","impression",{el:this,test:this.uuid,variant:a})}),t.unobserve(e.target)):window.tegna.log("_abtest","notIntersecting")})});e.observe(this)}else t[n].active=!1})}}window.customElements.define("tegna-ab",i)}
//# sourceMappingURL=above-page-scripts.js.map</script>
    <div data-module="page" data-state="ready" class="page"
         data-embed="false"
         data-platform="desktop"
         data-page-type="article"
         data-ux-tracking-url="https://abtesting.tegnadigital.com/api/SendUxAbTestingData?code=e3Irhqa83MHyggLHJNGt7sl3WgZTv8oWNph7h8cZQVYnCKtAcrDb9w=="
         data-api-key=""
         data-environment="Production"
         data-is-monitor="false"
         data-is-preview="false"
         data-site-id="285"
         data-primarydomain="khou.com"
         data-environment-base-url="https://www.khou.com/"
         data-call-letters="KHOU"
         data-full-environment="KHOU"
         data-twitter-id="KHOU"
         data-fban="1981419195445082"
         data-refresh="420"
         data-dfpid="32805352"
         data-comscoreid="19962895"
         data-recaptchasitekey="6LdhZY8UAAAAANQxx8Y6_JJZSJtONlMiM_yiKTah"
         data-targeting-video_included="true"
         data-targeting-ttid="5a155c18-d5a3-4921-afd7-1f8a831536d2"
         data-targeting-pgtype="article"
         data-targeting-topic_section=""
         data-targeting-url="https://www.khou.com/article/news/local/selena-rodeo-houston-video/285-5a155c18-d5a3-4921-afd7-1f8a831536d2"
         data-is-video="false"
         data-is-longform="false"
         data-gptid="tx-houston-KHOU-B3351_DesktopTablet"
         data-tealium-url="//tags.tiqcdn.com/utag/tegna/khou-redesign-desktop/prod/utag"
         data-taboola-url="https://www.khou.com/article/news/local/selena-rodeo-houston-video/285-5a155c18-d5a3-4921-afd7-1f8a831536d2"
         data-elvs-id=""
         data-elvs-stream-url=""
         data-is-elvs-disabled="true"
         data-tealium-id-comscore="1"data-tealium-id-datasphere="458"data-tealium-id-dealboss="515"data-tealium-id-googleanalytics="470"data-tealium-id-oneplusx="543"data-tealium-id-simplifi="535"data-tealium-id-taboola="520"data-tealium-id-truanthem="442"data-tealium-id-visto="457"         >
            <div class="page__top">

    <div class="universal-ad" data-module="universal-ad">
        <div class="universal-ad__close-button">
            <img src="/assets/shared-images/icons/close-menu.svg" alt="x" width="14" height="14" />
        </div>
        <div class="universal-ad__ad">
        <div data-module="ad" class="ad ad_position_article_universal ad_background_true"
         data-status="new"
         data-path="/32805352/tx-houston-KHOU-B3351_DesktopTablet/article_universal/news/local"
         data-sizes="[[1140,250],[970,250],[728,90],[1,1]]"
         data-delay="0"
         data-position="article_universal"
         data-refresh-interval="0"
         data-refresh-enabled="false"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id=""
         data-page-type="article">
        <div class="ad__inner ad__inner_border_false ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
        </div>
    </div>
            </div>
            <div class="page__header">
<header data-module="header" class="header"
        data-alerts="false"
        data-facebook-app-id="1981419195445082"
        data-twitter-id="KHOU">
    <a class="header__skip" href="#main" tabindex="1">Skip Navigation</a>
    <div class="header__main">
        <ul class="header__social-list">
            <li class="header__social-item">
                <a class="header__social-link header__social-link_type_facebook" data-tracking-action="click" data-tracking-category="sharing" data-tracking-label="facebook">Share on Facebook</a>
            </li>
            <li class="header__social-item">
                <a class="header__social-link header__social-link_type_twitter" data-tracking-action="click" data-tracking-category="sharing" data-tracking-label="twitter">Share on Twitter</a>
            </li>
            <li class="header__social-item">
                <a class="header__social-link header__social-link_type_sms" data-tracking-action="click" data-tracking-category="sharing" data-tracking-label="sms">Share on SMS</a>
            </li>
            <li class="header__social-item">
                <a class="header__social-link header__social-link_type_email" data-tracking-action="click" data-tracking-category="sharing" data-tracking-label="email">Share on Email</a>
            </li>
        </ul>
        <div class="header__main-inner">
            <div class="header__hamburger">
                <div class="header__hamburger-icon-container">
                    <div class="header__hamburger-icon"></div>
                </div>
            </div>
            <a class="header__station-branding" href="/" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="masthead-logo">
                <img class="header__logo" alt="Home" src="/assets/shared-images/logos/khou.png" loading="eager" width="112" onload="this.parentElement.style.opacity='1';" />
            </a>
            <nav class="header__not-logo">
                <h2 class="header__nav-heading">Navigation</h2>
                <div class="header__tooltip-overlay"></div>
                <ul class="header__nav">
                        <li class="header__nav-item">
                            <a class="header__nav-link header__nav-link_has-subnav_true" href="/news" target="_self" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="News">
                                        <span class="header__nav-label">News</span>
                            </a>
                            <div class="header__subnav">
                                <div class="header__subnav-groups">
                                    <div class="header__subnav-group header__subnav-group_name_back">
                                        <ul class="header__subnav-list">
                                            <li class="header__subnav-item header__subnav-item_type_back">
                                                <a class="header__subnav-link header__subnav-link_type_back" href="#">
                                                    <span class="header__subnav-label header__subnav-label_type_back">Back</span>
                                                </a>
                                            </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_topics">
                                        <ul class="header__subnav-list">
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/local" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Local">
                                                                    <span class="header__subnav-label">Local</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/sports" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Sports">
                                                                    <span class="header__subnav-label">Sports</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/texas" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Texas">
                                                                    <span class="header__subnav-label">Texas</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/politics" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Politics">
                                                                    <span class="header__subnav-label">Politics</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/nation-world" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Nation World">
                                                                    <span class="header__subnav-label">Nation World</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/investigations" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Investigations">
                                                                    <span class="header__subnav-label">Investigations</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/entertainment" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Entertainment">
                                                                    <span class="header__subnav-label">Entertainment</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/heartwarming" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Heartwarming">
                                                                    <span class="header__subnav-label">Heartwarming</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/features" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Features">
                                                                    <span class="header__subnav-label">Features</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/verify" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="VERIFY">
                                                                    <span class="header__subnav-label">VERIFY</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/health" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Health">
                                                                    <span class="header__subnav-label">Health</span>
                                                        </a>
                                                    </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_featured">
                                            <div class="header__featured-title">Latest News Stories</div>
<div data-module="story-row" class="story-row">
    <ul class="story-row__list">
            <li class="story-row__item story-row__item_size_half">
                    <div class="story-row__photo">
                        <div class="story-row__ratio-enforcer">
                            <div class="story-row__ratio-enforced">
                                <a class="story-row__image-link" href="/article/news/local/selena-rodeo-houston-video/285-5a155c18-d5a3-4921-afd7-1f8a831536d2" aria-label="Read Video: Selena performed at Houston Rodeo on this date 27 years ago" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; Video: Selena performed at Houston Rodeo on this date 27 years ago">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="Video: Selena performed at Houston Rodeo on this date 27 years ago" width="" height="" src="https://media.khou.com/assets/KHOU/images/1df667b5-4a11-4b87-9e0c-56f446039b35/1df667b5-4a11-4b87-9e0c-56f446039b35_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="Video: Selena performed at Houston Rodeo on this date 27 years ago" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.khou.com/assets/KHOU/images/1df667b5-4a11-4b87-9e0c-56f446039b35/1df667b5-4a11-4b87-9e0c-56f446039b35_360x203.jpg" data-srcset="https://media.khou.com/assets/KHOU/images/1df667b5-4a11-4b87-9e0c-56f446039b35/1df667b5-4a11-4b87-9e0c-56f446039b35_16x9.jpg 16w, https://media.khou.com/assets/KHOU/images/1df667b5-4a11-4b87-9e0c-56f446039b35/1df667b5-4a11-4b87-9e0c-56f446039b35_140x79.jpg 140w, https://media.khou.com/assets/KHOU/images/1df667b5-4a11-4b87-9e0c-56f446039b35/1df667b5-4a11-4b87-9e0c-56f446039b35_360x203.jpg 360w, https://media.khou.com/assets/KHOU/images/1df667b5-4a11-4b87-9e0c-56f446039b35/1df667b5-4a11-4b87-9e0c-56f446039b35_540x304.jpg 540w, https://media.khou.com/assets/KHOU/images/1df667b5-4a11-4b87-9e0c-56f446039b35/1df667b5-4a11-4b87-9e0c-56f446039b35_750x422.jpg 750w, https://media.khou.com/assets/KHOU/images/1df667b5-4a11-4b87-9e0c-56f446039b35/1df667b5-4a11-4b87-9e0c-56f446039b35_1140x641.jpg 1140w, https://media.khou.com/assets/KHOU/images/1df667b5-4a11-4b87-9e0c-56f446039b35/1df667b5-4a11-4b87-9e0c-56f446039b35_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script></div>
                                </a>
                            </div>
                        </div>
                    </div>
                    <div class="story-row__text">
                        <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="/article/news/local/selena-rodeo-houston-video/285-5a155c18-d5a3-4921-afd7-1f8a831536d2" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; Video: Selena performed at Houston Rodeo on this date 27 years ago">Video: Selena performed at Houston Rodeo on this date 27 years ago</a></h4>
                                            </div>
            </li>
            <li class="story-row__item story-row__item_size_half">
                    <div class="story-row__photo">
                        <div class="story-row__ratio-enforcer">
                            <div class="story-row__ratio-enforced">
                                <a class="story-row__image-link" href="/article/news/crime/man-arrested-charged-with-murder-harris-county-business-tallshadows-drive/285-e54788ac-f552-47f5-ac22-5be73c699495" aria-label="Read Suspect facing murder charge for man&#x27;s death outside of North Harris Co. business" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; Suspect facing murder charge for man&#x27;s death outside of North Harris Co. business">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="Suspect facing murder charge for man's death outside of North Harris Co. business" width="" height="" src="https://media.khou.com/assets/KHOU/images/cd45a4f2-61fb-4fe5-bb41-a13c19d9bee1/cd45a4f2-61fb-4fe5-bb41-a13c19d9bee1_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="Suspect facing murder charge for man's death outside of North Harris Co. business" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.khou.com/assets/KHOU/images/cd45a4f2-61fb-4fe5-bb41-a13c19d9bee1/cd45a4f2-61fb-4fe5-bb41-a13c19d9bee1_360x203.jpg" data-srcset="https://media.khou.com/assets/KHOU/images/cd45a4f2-61fb-4fe5-bb41-a13c19d9bee1/cd45a4f2-61fb-4fe5-bb41-a13c19d9bee1_16x9.jpg 16w, https://media.khou.com/assets/KHOU/images/cd45a4f2-61fb-4fe5-bb41-a13c19d9bee1/cd45a4f2-61fb-4fe5-bb41-a13c19d9bee1_140x79.jpg 140w, https://media.khou.com/assets/KHOU/images/cd45a4f2-61fb-4fe5-bb41-a13c19d9bee1/cd45a4f2-61fb-4fe5-bb41-a13c19d9bee1_360x203.jpg 360w, https://media.khou.com/assets/KHOU/images/cd45a4f2-61fb-4fe5-bb41-a13c19d9bee1/cd45a4f2-61fb-4fe5-bb41-a13c19d9bee1_540x304.jpg 540w, https://media.khou.com/assets/KHOU/images/cd45a4f2-61fb-4fe5-bb41-a13c19d9bee1/cd45a4f2-61fb-4fe5-bb41-a13c19d9bee1_750x422.jpg 750w, https://media.khou.com/assets/KHOU/images/cd45a4f2-61fb-4fe5-bb41-a13c19d9bee1/cd45a4f2-61fb-4fe5-bb41-a13c19d9bee1_1140x641.jpg 1140w, https://media.khou.com/assets/KHOU/images/cd45a4f2-61fb-4fe5-bb41-a13c19d9bee1/cd45a4f2-61fb-4fe5-bb41-a13c19d9bee1_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script></div>
                                </a>
                            </div>
                        </div>
                    </div>
                    <div class="story-row__text">
                        <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="/article/news/crime/man-arrested-charged-with-murder-harris-county-business-tallshadows-drive/285-e54788ac-f552-47f5-ac22-5be73c699495" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; Suspect facing murder charge for man&#x27;s death outside of North Harris Co. business">Suspect facing murder charge for man&#x27;s death outside of North Harris Co. business</a></h4>
                                            </div>
            </li>
    </ul>
</div>                                    </div>
                                </div>
                            </div>
                        </li>
                        <li class="header__nav-item">
                            <a class="header__nav-link header__nav-link_has-subnav_true" href="/weather/" target="_self" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Weather">
                                        <span class="header__nav-label">Weather</span>
                            </a>
                            <div class="header__subnav">
                                <div class="header__subnav-groups">
                                    <div class="header__subnav-group header__subnav-group_name_back">
                                        <ul class="header__subnav-list">
                                            <li class="header__subnav-item header__subnav-item_type_back">
                                                <a class="header__subnav-link header__subnav-link_type_back" href="#">
                                                    <span class="header__subnav-label header__subnav-label_type_back">Back</span>
                                                </a>
                                            </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_topics">
                                        <ul class="header__subnav-list">
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/forecast" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Forecast">
                                                                    <span class="header__subnav-label">Forecast</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/radar" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Radar">
                                                                    <span class="header__subnav-label">Radar</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/10-day" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="10-Day">
                                                                    <span class="header__subnav-label">10-Day</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/maps" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Maps">
                                                                    <span class="header__subnav-label">Maps</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/hurricane" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Hurricane">
                                                                    <span class="header__subnav-label">Hurricane</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/traffic" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Traffic">
                                                                    <span class="header__subnav-label">Traffic</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="https://www.youtube.com/watch?v=npm2Wb_g8DU&amp;list=PLQHbZRZgPITmHEpastjtwBMmwDDpwY4F8" target="_blank" rel="noopener" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Weather School">
                                                                    <span class="header__subnav-label">Weather School</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/webcams" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Live Webcams">
                                                                    <span class="header__subnav-label">Live Webcams</span>
                                                        </a>
                                                    </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_featured">
                                            <div class="header__featured-title">Latest Weather Stories</div>
<div data-module="story-row" class="story-row">
    <ul class="story-row__list">
            <li class="story-row__item story-row__item_size_half">
                    <div class="story-row__photo">
                        <div class="story-row__ratio-enforcer">
                            <div class="story-row__ratio-enforced">
                                <a class="story-row__image-link" href="/article/weather/san-antonio-forecast-kens-5-texas/273-608077503" aria-label="Read Icy conditions in San Antonio and the Hill Country" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; Icy conditions in San Antonio and the Hill Country">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="Icy conditions in San Antonio and the Hill Country" width="" height="" src="https://media.khou.com/assets/KENS/images/ea53fe59-b5c6-423b-9bd8-c7ddd92c87e1/ea53fe59-b5c6-423b-9bd8-c7ddd92c87e1_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="Icy conditions in San Antonio and the Hill Country" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.khou.com/assets/KENS/images/ea53fe59-b5c6-423b-9bd8-c7ddd92c87e1/ea53fe59-b5c6-423b-9bd8-c7ddd92c87e1_360x203.jpg" data-srcset="https://media.khou.com/assets/KENS/images/ea53fe59-b5c6-423b-9bd8-c7ddd92c87e1/ea53fe59-b5c6-423b-9bd8-c7ddd92c87e1_16x9.jpg 16w, https://media.khou.com/assets/KENS/images/ea53fe59-b5c6-423b-9bd8-c7ddd92c87e1/ea53fe59-b5c6-423b-9bd8-c7ddd92c87e1_140x79.jpg 140w, https://media.khou.com/assets/KENS/images/ea53fe59-b5c6-423b-9bd8-c7ddd92c87e1/ea53fe59-b5c6-423b-9bd8-c7ddd92c87e1_360x203.jpg 360w, https://media.khou.com/assets/KENS/images/ea53fe59-b5c6-423b-9bd8-c7ddd92c87e1/ea53fe59-b5c6-423b-9bd8-c7ddd92c87e1_540x304.jpg 540w, https://media.khou.com/assets/KENS/images/ea53fe59-b5c6-423b-9bd8-c7ddd92c87e1/ea53fe59-b5c6-423b-9bd8-c7ddd92c87e1_750x422.jpg 750w, https://media.khou.com/assets/KENS/images/ea53fe59-b5c6-423b-9bd8-c7ddd92c87e1/ea53fe59-b5c6-423b-9bd8-c7ddd92c87e1_1140x641.jpg 1140w, https://media.khou.com/assets/KENS/images/ea53fe59-b5c6-423b-9bd8-c7ddd92c87e1/ea53fe59-b5c6-423b-9bd8-c7ddd92c87e1_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script></div>
                                </a>
                            </div>
                        </div>
                    </div>
                    <div class="story-row__text">
                        <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="/article/weather/san-antonio-forecast-kens-5-texas/273-608077503" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; Icy conditions in San Antonio and the Hill Country">Icy conditions in San Antonio and the Hill Country</a></h4>
                                            </div>
            </li>
            <li class="story-row__item story-row__item_size_half">
                    <div class="story-row__photo">
                        <div class="story-row__ratio-enforcer">
                            <div class="story-row__ratio-enforced">
                                <a class="story-row__image-link" href="/article/weather/forecast/houston-weather-forecast/285-00e4f78e-d8d0-4b97-8261-a1a441c52093" aria-label="Read Houston forecast: Cold weather is here to stay at least through the weekend" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; Houston forecast: Cold weather is here to stay at least through the weekend">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="Houston forecast: Cold weather is here to stay at least through the weekend" width="" height="" src="https://media.khou.com/assets/KHOU/images/4f7d0cab-9de5-4730-bd7b-75d148220b52/4f7d0cab-9de5-4730-bd7b-75d148220b52_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="Houston forecast: Cold weather is here to stay at least through the weekend" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.khou.com/assets/KHOU/images/4f7d0cab-9de5-4730-bd7b-75d148220b52/4f7d0cab-9de5-4730-bd7b-75d148220b52_360x203.jpg" data-srcset="https://media.khou.com/assets/KHOU/images/4f7d0cab-9de5-4730-bd7b-75d148220b52/4f7d0cab-9de5-4730-bd7b-75d148220b52_16x9.jpg 16w, https://media.khou.com/assets/KHOU/images/4f7d0cab-9de5-4730-bd7b-75d148220b52/4f7d0cab-9de5-4730-bd7b-75d148220b52_140x79.jpg 140w, https://media.khou.com/assets/KHOU/images/4f7d0cab-9de5-4730-bd7b-75d148220b52/4f7d0cab-9de5-4730-bd7b-75d148220b52_360x203.jpg 360w, https://media.khou.com/assets/KHOU/images/4f7d0cab-9de5-4730-bd7b-75d148220b52/4f7d0cab-9de5-4730-bd7b-75d148220b52_540x304.jpg 540w, https://media.khou.com/assets/KHOU/images/4f7d0cab-9de5-4730-bd7b-75d148220b52/4f7d0cab-9de5-4730-bd7b-75d148220b52_750x422.jpg 750w, https://media.khou.com/assets/KHOU/images/4f7d0cab-9de5-4730-bd7b-75d148220b52/4f7d0cab-9de5-4730-bd7b-75d148220b52_1140x641.jpg 1140w, https://media.khou.com/assets/KHOU/images/4f7d0cab-9de5-4730-bd7b-75d148220b52/4f7d0cab-9de5-4730-bd7b-75d148220b52_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script></div>
                                </a>
                            </div>
                        </div>
                    </div>
                    <div class="story-row__text">
                        <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="/article/weather/forecast/houston-weather-forecast/285-00e4f78e-d8d0-4b97-8261-a1a441c52093" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; Houston forecast: Cold weather is here to stay at least through the weekend">Houston forecast: Cold weather is here to stay at least through the weekend</a></h4>
                                            </div>
            </li>
    </ul>
</div>                                    </div>
                                </div>
                            </div>
                        </li>
                        <li class="header__nav-item">
                            <a class="header__nav-link header__nav-link_has-subnav_false" href="/near-me" target="_self" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Near Me">
                                        <span class="header__nav-label">Near Me</span>
                            </a>
                        </li>
                        <li class="header__nav-item">
                            <a class="header__nav-link header__nav-link_has-subnav_false" href="/verify" target="_self" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="VERIFY">
                                        <span class="header__nav-label">VERIFY</span>
                            </a>
                        </li>
                        <li>
                            <div class="header__mini-live-video">
<div data-module="watch-live" class="watch-live watch-live_active_false" data-watch-enabled="true">
    <a class="watch-live__cta" href="/watch">
        <span class="watch-live__label">Watch</span>
    </a>
    <div class="watch-live__mini-live-video watch-live__mini-live-video_active_false">
        <a class="watch-live__video-link" href="/watch">
    <div data-module="mini-live-video" class="mini-live-video mini-live-video_state_stopped" data-is-watch="false">    
        <div class="mini-live-video__player"></div>
    </div>        </a>
    </div>
</div>                            </div>
                        </li>
                    <li class="header__nav-search header__nav-search_type_search">
                        <a class="header__nav-link header__nav-link_type_search" href="/search">
                            <label class="header__nav-label header__nav-label_type_search" for="site_search">Search</label>
                        </a>
                        <div class="header__subnav header__subnav_type_search">
                            <div class="header__subnav-group header__subnav-group_name_search">
                                <form class="header__search-form" method="GET" action="/search">
                                    <label class="header__search-label" for="site_search">Search:</label>
                                    <input class="header__search-box" placeholder="Search khou.com" id="site_search" type="search" name="q" />
                                    <button class="header__search-submit" type="submit">Search</button>
                                </form>
                            </div>
                            <button class="header__close-button" aria-label="close"></button>
                        </div>
                    </li>
                </ul>
                    <div class="header__sponsor">
        <div data-module="ad" class="ad ad_position_masthead_sponsor ad_background_false"
         data-status="new"
         data-path="/32805352/tx-houston-KHOU-B3351_DesktopTablet/masthead_sponsor/news/local"
         data-sizes="[[112,38]]"
         data-delay="0"
         data-position="masthead_sponsor"
         data-refresh-interval="0"
         data-refresh-enabled="false"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id=""
         data-page-type="article">
        <div class="ad__inner ad__inner_border_false ad__inner_background_false" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
                    </div>
                <a class="header__weather-link" href="/weather" data-tracking-action="weather-summary/weatherClicked" data-tracking-category="link click" data-tracking-label="Link From: https://www.khou.com/article/news/local/selena-rodeo-houston-video/285-5a155c18-d5a3-4921-afd7-1f8a831536d2">
                    <div class="header__weather">
                        <div class="header__weather-desktop-info">
                            <div class="header__weather-label header__weather-label_alerts_false">Right Now</div>
                            <div class="header__weather-city header__weather-city_alerts_false">Houston, TX&nbsp;&raquo;</div>
                        </div>
                        <div class="header__weather-content">
                            <div class="header__weather-info header__weather-info_alerts_false">
                                <div class="header__weather-temp header__weather-temp_alerts_false">44&deg;</div>

                                <div class="header__weather-icon header__weather-icon_alerts_false">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="" width="26px" height="26px" src="/assets/shared-images/weather-icons/wx-67_8x8.png" /><img class="lazy-image__image lazy-image__image_blur_false" alt="" width="26px" height="26px" src="/assets/shared-images/backgrounds/blank.png" data-src="/assets/shared-images/weather-icons/wx-67_32x32.png" data-srcset="/assets/shared-images/weather-icons/wx-67_8x8.png 8w, /assets/shared-images/weather-icons/wx-67_16x16.png 16w, /assets/shared-images/weather-icons/wx-67_32x32.png 32w, /assets/shared-images/weather-icons/wx-67_64x64.png 64w, /assets/shared-images/weather-icons/wx-67_128x128.png 128w, /assets/shared-images/weather-icons/wx-67_210x210.png 210w" sizes="26px" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script><noscript><img class="lazy-image__nojs-image" alt="" width="26px" height="26px" src="/assets/shared-images/weather-icons/wx-67_32x32.png" srcset="/assets/shared-images/weather-icons/wx-67_8x8.png 8w, /assets/shared-images/weather-icons/wx-67_16x16.png 16w, /assets/shared-images/weather-icons/wx-67_32x32.png 32w, /assets/shared-images/weather-icons/wx-67_64x64.png 64w, /assets/shared-images/weather-icons/wx-67_128x128.png 128w, /assets/shared-images/weather-icons/wx-67_210x210.png 210w" sizes="26px" loading="lazy" /></noscript></div>
                                </div>
                            </div>
                            <div class="header__weather-city header__weather-city_alerts_false">Houston, TX&nbsp;&raquo;</div>
                        </div>
                    </div>
                </a>
            <div class="header__alerts">
                    <a class="header__alert header__alert_type_weather header__alert_visible_false" href="/weather/alerts" data-tracking-action="weatheralert/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: https://www.khou.com/article/news/local/selena-rodeo-houston-video/285-5a155c18-d5a3-4921-afd7-1f8a831536d2">Weather</a>
                    <a class="header__alert header__alert_type_closings header__alert_visible_false" href="/closings" data-tracking-action="closingsalert/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: https://www.khou.com/article/news/local/selena-rodeo-houston-video/285-5a155c18-d5a3-4921-afd7-1f8a831536d2">Closings</a>
            </div>
            </nav>
        </div>
    </div>
    <div class="header__featured">
            <div class="header__featured-arrow header__featured-arrow_direction_previous"><img src="/images/header/arrow.png" width="14" height="14" loading="eager" alt="" /></div>
            <div class="header__featured-inner">
                <ul class="header__featured-list">
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="http://khou.com/living">Living in the Lone Star</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/verify">VERIFY</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/investigations">Investigations</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="http://khou.com/attheborder">At the border</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="https://www.khou.com/email">Sign up for our newsletter</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="https://www.khou.com/astroworld">Tragedy at Astroworld</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="http://khou.com/education">Education Station</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="http://khou.com/email">Get our newsletters</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/coronavirus-covid-19">Coronavirus</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/section/you-ask-we-answer">You ask, we answer</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/heroesnextdoor">Heroes Nextdoor</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/greatday">Great Day Houston</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/webcams">Live Webcams</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="http://khou.com/vaccine">COVID Vaccine </a>
                        </li>
                </ul>
            </div>
            <div class="header__featured-arrow header__featured-arrow_direction_next"><img src="/images/header/arrow.png" width="14" height="14" loading="eager" alt="" /></div>
    </div>
</header>            </div>
            <div class="page__dock">
                    <div class="page__breaking-news-alerts">
    <div data-module="breaking-news-alerts" class="breaking-news-alerts breaking-news-alerts_visible_false">
        <div class="breaking-news-alerts__wrap">
            <div class="breaking-news-alerts__close"></div>
            <div class="breaking-news-alerts__label">Breaking News</div>
            <ul class="breaking-news-alerts__headline-wrap">
                <template class="breaking-news-alerts__template">
                    <li class="breaking-news-alerts__item">
                        <a class="breaking-news-alerts__link" href="#" data-tracking="breaking-news-alerts/linkClicked">
                            <span class="breaking-news-alerts__headline"></span>
                            <span class="breaking-news-alerts__read-more">Read More &raquo;</span>
                        </a>
                    </li>
                </template>
            </ul>
            <a class="breaking-news-alerts__more" href="/breaking-news" data-tracking="breaking-news-alerts/moreClicked">More (<span class="breaking-news-alerts__count"></span>) &raquo;</a>
        </div>
    </div>
                    </div>
            </div>
        <main class="page__main" id="main">
            <div class="page__grid">
                


    <div data-module="grid" class="grid grid_version_2-1">
        <div class="grid__section grid__section_theme_default" data-theme="default">
            <div class="grid__theme-elements">
                <div class="grid__theme-design-1"></div>
                <div class="grid__theme-design-2"></div>
                <div class="grid__theme-design-3"></div>
                <div class="grid__theme-design-4"></div>
            </div>
            <div class="grid__content grid__content_full-width_false">
                <div class="grid__main grid__main_sticky_right grid__main_full-width_false">
                        <div class="grid__cell grid__cell_columns_2" data-columns="2">
                                <div class="grid__module grid__module_loaded_true">
                                    <div class="grid__module-sizer grid__module-sizer_name_article" data-module-sizer="article" data-count="1">
<article class="article" data-module="article"
         data-article-id="5a155c18-d5a3-4921-afd7-1f8a831536d2"
         data-title="Video: Selena performed at Houston Rodeo on this date 27 years ago"
         data-seo-title="Video from Selena&#x27;s Houston Rodeo performance on Feb. 26, 1995"
         data-abstract="Just a month after this performance, the artist was shot and killed."
         data-section="news"
         data-subsection="local"
         data-topic=""
         data-subtopic=""
         data-url="www.khou.com/article/news/local/selena-rodeo-houston-video/285-5a155c18-d5a3-4921-afd7-1f8a831536d2"
         data-gpt-network-code="32805352"
         data-categories="local,entertainment,rodeohouston,news"
         data-author="KHOU 11 Staff"
         data-keywords="local,entertainment,rodeohouston,news"
         data-has-video="true"
         data-watson-keywords="Tejano star Selena Quintanilla-P&#xE9;rez,big artists,Editor&#x27;s note,last major performance,coverage of Selena Last year"
         data-t1-publisher="rklein@tegna.com"
         data-is-cct="false"
         data-original-headline="Video: Selena performed at Houston Rodeo on this date 27 years ago"
         data-content-score="75"
         data-tracking-tags="">
        <a class="article__category" href="/section/local" data-tracking-category="article" data-tracking-action="click" data-tracking-label="article; topic; Local News">Local News</a>
        <h1 class="article__headline">Video: Selena performed at Houston Rodeo on this date 27 years ago</h1>
        <div class="article__summary">Just a month after this performance, the artist was shot and killed.</div>
        <div class="article__lead-asset">
        <div data-module="video" class="video"
             data-stream="https://video.tegna-media.com/assets/KHOU/videos/76299807-82f5-4765-b94b-a8c291ede675/76299807-82f5-4765-b94b-a8c291ede675.m3u8"
             data-float="true"
             data-thumbnail="https://media.khou.com/assets/KHOU/images/89021a63-8af0-4209-b4b7-4422ac17d40d/89021a63-8af0-4209-b4b7-4422ac17d40d_1920x1080.jpg"
             data-title="Selena Quintanilla added to Houston Rodeo&#x27;s Star Trail of Fame"
             data-description="The Queen of Tejano Music is still being celebrated at the Houston Livestock Show and Rodeo 25 years after her death."
             data-site="285"
             data-id="76299807-82f5-4765-b94b-a8c291ede675"
             data-mute="false"
             data-autoplay="true"
             data-link="https://www.khou.com/video/news/local/video/selena-quintanilla-added-to-houston-rodeos-star-trail-of-fame/285-76299807-82f5-4765-b94b-a8c291ede675"
             data-origin="clipping"
             data-section="news"
             data-subsection="local"
             data-subcategory="local"
             data-topic="video"
             data-subtopic=""
             data-categories="video,news,local"
             data-captions=""
             data-tracking-tags=""
             data-is-watch-player="false"
             data-is-live-now="VOD"
             data-is-ugc="false"
             data-is-cct="false"
             data-ugc-preroll-disabled="true"
             data-duration="121"
             data-disable-preroll-at-duration="0"
             data-disable-preroll="false"
             data-publica-id="9336"
             data-media-tailor-enabled="true"
             data-newscast-preroll-disabled="false"
             data-facebook-app-id="1981419195445082"
             data-sharing-twitter-title="Selena%20Quintanilla%20added%20to%20Houston%20Rodeo&#x27;s%20Star%20Trail%20of%20Fame"
             data-sharing-twitter-username="KHOU"
             data-a9-pubid="3276">
            <div class="video__ratio-enforcer">
                <div class="video__ratio-enforced">
                    <div class="video__docker-container">
                        <div class="video__docker">
                            <button class="video__docker-close" aria-label="undock video"></button>
                            <div class="video__ratio-enforcer">
                                <div class="video__ratio-enforced">
                                    <div class="video__inner">
                                        <div class="video__player-container">
                                            <div class="video__player"></div>
                                        </div>
                                    </div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
                                            <script type="application/ld+json">
                    {
                    "@context": "http://schema.org",
                    "@type": "VideoObject",
                    "name": "Selena Quintanilla added to Houston Rodeo&#x27;s Star Trail of Fame",
                    "description": "The Queen of Tejano Music is still being celebrated at the Houston Livestock Show and Rodeo 25 years after her death.",
                    "thumbnailUrl": "https://media.khou.com/assets/KHOU/images/89021a63-8af0-4209-b4b7-4422ac17d40d/89021a63-8af0-4209-b4b7-4422ac17d40d_1920x1080.jpg",
                    "uploadDate": "3/8/2020 6:14:11 PM",
                    "duration": "121",
                    "contentUrl": "https://www.khou.com/video/news/local/video/selena-quintanilla-added-to-houston-rodeos-star-trail-of-fame/285-76299807-82f5-4765-b94b-a8c291ede675",
                    "embedUrl": "https://media.khou.com/embeds/video/285-76299807-82f5-4765-b94b-a8c291ede675/iframe"
                    }
                        </script>
                </div>
        </div>
        <aside class="article__meta">
                <div class="article__author">
                    <span class="article__meta-label">Author:</span> KHOU 11 Staff
                </div>
                <div class="article__published">
                    <span class="article__meta-label">Published:</span> 3:35 PM CST February 26, 2022
                </div>
                <div class="article__updated">
                    <span class="article__meta-label">Updated:</span> 3:35 PM CST February 26, 2022
                </div>
    <div data-module="article-sharing" class="article-sharing">
        <a class="article-sharing__icon" href="https://www.facebook.com/dialog/share?app_id=1981419195445082&display=popup&href=https://www.khou.com/article/news/local/selena-rodeo-houston-video/285-5a155c18-d5a3-4921-afd7-1f8a831536d2&redirect_uri=https://www.khou.com/article/news/local/selena-rodeo-houston-video/285-5a155c18-d5a3-4921-afd7-1f8a831536d2" target="_blank" data-tracking-action="sharing/facebookLink" data-tracking-category="link click" data-tracking-label="Link From: https://www.khou.com/article/news/local/selena-rodeo-houston-video/285-5a155c18-d5a3-4921-afd7-1f8a831536d2">
            <img class="article-sharing__logo" alt="Facebook" src="/assets/shared-images/icons/facebook.svg" loading="eager" width="38" onload="this.parentElement.style.opacity='1';" />
        </a>
        <a class="article-sharing__icon" href="https://twitter.com/intent/tweet?text=Video:%20Selena%20performed%20at%20Houston%20Rodeo%20on%20this%20date%2027%20years%20ago&url=https://www.khou.com/article/news/local/selena-rodeo-houston-video/285-5a155c18-d5a3-4921-afd7-1f8a831536d2&via=KHOU" target="_blank" data-tracking-action="sharing/twitterLink" data-tracking-category="link click" data-tracking-label="Link From: https://www.khou.com/article/news/local/selena-rodeo-houston-video/285-5a155c18-d5a3-4921-afd7-1f8a831536d2">
            <img class="article-sharing__logo" alt="Twitter" src="/assets/shared-images/icons/twitter.svg" loading="eager" width="38" onload="this.parentElement.style.opacity='1';" />
        </a>
    </div>        </aside>
    <div class="article__body">
                    <div class="article__section article__section_type_text utility__text">
<p>HOUSTON — So many big artists from so many different music genres have graced the stage at <a href="/rodeo">RodeoHouston</a>. &nbsp;One of those artists was rising Tejano star <a href="/search?q=Selena">Selena Quintanilla-Pérez</a>.</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Selena performed at the Houston Livestock Show &amp; Rodeo 27 years ago today. It was her last major performance before her death, which would come just a month later.</p>                    </div>
                        <div class="article__section article__section_type_ad">
        <div data-module="ad" class="ad ad_position_article_mid1 ad_background_true"
         data-status="new"
         data-path="/32805352/tx-houston-KHOU-B3351_DesktopTablet/article_mid1/news/local"
         data-sizes="[[300,250],[1,1],[750,570],[1,2]]"
         data-delay="8"
         data-position="article_mid1"
         data-refresh-interval="33"
         data-refresh-enabled="true"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id=""
         data-page-type="article">
        <div class="ad__inner ad__inner_border_true ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
                        </div>
                    <div class="article__section article__section_type_text utility__text">
<p><em>Editor's note: The video above is from March of 2020, shortly after the 25th anniversary of Selena's Rodeo performance.</em></p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Selena performed in the Astrodome to a sold-out crowd on February 26, 1995. She was shot and killed on March 31.</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p><strong>After her death, Selena’s family released the RodeoHouston show as an album called <a href="https://qello.com/concert/The-Last-Concert-Live-From-The-Astrodome-7337">“Live! The Last Concert.”</a>&nbsp; You can watch some of those video clips on YouTube below.</strong></p>                    </div>
                                <div class="article__section article__section_type_embed">
                                    <div style="left: 0; width: 100%; height: 0; position: relative; padding-bottom: 56.25%;"><iframe src="https://www.youtube.com/embed/kqyUf19c_7Y?rel=0" style="border: 0; top: 0; left: 0; width: 100%; height: 100%; position: absolute;" allowfullscreen scrolling="no" allow="encrypted-media; accelerometer; clipboard-write; gyroscope; picture-in-picture"></iframe></div>
                                </div>
                                <div class="article__section article__section_type_embed">
                                    <div style="left: 0; width: 100%; height: 0; position: relative; padding-bottom: 56.25%;"><iframe src="https://www.youtube.com/embed/sADUuDB2MzI?rel=0" style="border: 0; top: 0; left: 0; width: 100%; height: 100%; position: absolute;" allowfullscreen scrolling="no" allow="encrypted-media; accelerometer; clipboard-write; gyroscope; picture-in-picture"></iframe></div>
                                </div>
                                <div class="article__section article__section_type_embed">
                                    <div style="left: 0; width: 100%; height: 0; position: relative; padding-bottom: 56.25%;"><iframe src="https://www.youtube.com/embed/kqyUf19c_7Y?rel=0" style="border: 0; top: 0; left: 0; width: 100%; height: 100%; position: absolute;" allowfullscreen scrolling="no" allow="encrypted-media; accelerometer; clipboard-write; gyroscope; picture-in-picture"></iframe></div>
                                </div>
                                <div class="article__section article__section_type_embed">
                                    <div style="left: 0; width: 100%; height: 0; position: relative; padding-bottom: 56.25%;"><iframe src="https://www.youtube.com/embed/sD6xKP11vfE?rel=0" style="border: 0; top: 0; left: 0; width: 100%; height: 100%; position: absolute;" allowfullscreen scrolling="no" allow="encrypted-media; accelerometer; clipboard-write; gyroscope; picture-in-picture"></iframe></div>
                                </div>
                                <div class="article__section article__section_type_embed">
                                    <div style="left: 0; width: 100%; height: 0; position: relative; padding-bottom: 56.25%;"><iframe src="https://www.youtube.com/embed/FwZTgDjRLM0?rel=0" style="border: 0; top: 0; left: 0; width: 100%; height: 100%; position: absolute;" allowfullscreen scrolling="no" allow="encrypted-media; accelerometer; clipboard-write; gyroscope; picture-in-picture"></iframe></div>
                                </div>
                    <div class="article__section article__section_type_text utility__text">
<h2>KHOU 11 coverage of Selena</h2>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Last year, we went into the KHOU 11 archives for coverage of Selena. We found the newscast from the day Selena was killed. That video has now been viewed more than one million times.</p>                    </div>
                                <div class="article__section article__section_type_embed">
                                    <div style="left: 0; width: 100%; height: 0; position: relative; padding-bottom: 75%;"><iframe src="https://www.youtube.com/embed/RymLJQV5ShU?rel=0" style="border: 0; top: 0; left: 0; width: 100%; height: 100%; position: absolute;" allowfullscreen scrolling="no" allow="encrypted-media; accelerometer; clipboard-write; gyroscope; picture-in-picture"></iframe></div>
                                </div>
                    <div class="article__section article__section_type_text utility__text">
<p>And KHOU 11's Ron Treviño spoke one-on-one with Selena about her rise to fame one year before she was killed.&nbsp;</p>                    </div>
                                <div class="article__section article__section_type_embed">
                                    <div style="left: 0; width: 100%; height: 0; position: relative; padding-bottom: 56.25%;"><iframe src="https://www.youtube.com/embed/JXkIrUwVDqs?rel=0" style="border: 0; top: 0; left: 0; width: 100%; height: 100%; position: absolute;" allowfullscreen scrolling="no" allow="encrypted-media; accelerometer; clipboard-write; gyroscope; picture-in-picture"></iframe></div>
                                </div>

<div data-module="related-stories" class="related-stories">
    <h2 class="related-stories__heading">Related Articles</h2>
    <ul class="related-stories__stories">
            <li class="related-stories__story">
                <a class="related-stories__link" href="http://www.khou.com/article/news/local/selena-movie-inducted-into-national-film-registry/503-cc6cd3f1-d4c2-4b15-951d-e23886b31c66" data-tracking-action="related-article/linkClicked" data-tracking-category="link click" data-tracking-label="&#x27;Selena&#x27; movie included in annual list of 25 most influential motion pictures, inducted into National Film Registry">&#x27;Selena&#x27; movie included in annual list of 25 most influential motion pictures, inducted into National Film Registry</a>
            </li>
            <li class="related-stories__story">
                <a class="related-stories__link" href="http://www.khou.com/article/news/local/selena-legacy-in-corpus-christi/503-30e1ceba-a555-4516-a591-b62ab4dbb5e0" data-tracking-action="related-article/linkClicked" data-tracking-category="link click" data-tracking-label="How Selena Quintanilla&#x27;s legacy has impacted an entire culture">How Selena Quintanilla&#x27;s legacy has impacted an entire culture</a>
            </li>
            <li class="related-stories__story">
                <a class="related-stories__link" href="http://www.khou.com/article/life/selena-tejano-queen-quintanilla-prez-podcast-yolanda-saldvar/285-d1676e4d-e0ea-4e7d-a895-1ae2935f353f" data-tracking-action="related-article/linkClicked" data-tracking-category="link click" data-tracking-label="Exploring the life and legacy of Selena, 25 years later">Exploring the life and legacy of Selena, 25 years later</a>
            </li>
    </ul>
</div>                    <div class="article__section article__section_type_text utility__text">
<h3><a href="https://twitter.com/khouron?lang=en" ping="/url?sa=t&source=web&rct=j&url=https://twitter.com/khouron%3Flang%3Den&ved=2ahUKEwiatfDRo572AhWaQPUHHWFaDs8QtwJ6BAgIEAM&sqi=2">&nbsp;</a></h3>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>&nbsp;</p>                    </div>
    </div>
    <script type="application/ld+json">
        {
  "@context": "http://schema.org",
  "@type": "NewsArticle",
  "headline": "Video: Selena performed at Houston Rodeo on this date 27 years ago",
  "datePublished": "3:35 PM CST February 26, 2022",
  "dateModified": "3:35 PM CST February 26, 2022",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.khou.com/article/news/local/selena-rodeo-houston-video/285-5a155c18-d5a3-4921-afd7-1f8a831536d2"
  },
  "author": {
    "@type": "Person",
    "name": "KHOU 11 Staff"
  },
  "publisher": {
    "@type": "Organization",
    "name": "KHOU",
    "logo": {
      "@type": "ImageObject",
      "url": "https://www.khou.com/assets/shared-images/amp-logos/khou.png",
      "width": 340,
      "height": 60
    }
  }
}
    </script>
</article>                                    </div>
                                </div>
                                <div class="grid__module grid__module_loaded_true">
                                    <div class="grid__module-sizer grid__module-sizer_name_taboola" data-module-sizer="taboola" data-count="1">
    <div data-module="taboola" class="taboola" id="taboola-below-article-thumbnails-2nd-::articleNumber::"
         data-page-type="article"
         data-ad="below_taboola"
         data-mode="thumbnails-h2"
         data-target-type="mix"
         data-placement="Below Article Thumbnails 2nd"
         data-url="http://www.khou.com::contentUrl::"
         data-id="taboola-below-article-thumbnails-2nd-::articleNumber::">
    </div>
                                    </div>
                                </div>
                        </div>
                </div>

                    <div class="grid__sticky-column grid__sticky-column_side_right">
                        <div class="grid__sticky-content" data-columns="1">
                                <div class="grid__module grid__module_loaded_true">
                                    <div class="grid__module-sizer grid__module-sizer_name_ad" data-module-sizer="ad" data-count="1">
        <div data-module="ad" class="ad ad_position_article_atf ad_background_true"
         data-status="new"
         data-path="/32805352/tx-houston-KHOU-B3351_DesktopTablet/article_atf/news/local"
         data-sizes="[[300,250]]"
         data-delay="8"
         data-position="article_atf"
         data-refresh-interval="33"
         data-refresh-enabled="true"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id=""
         data-page-type="article">
        <div class="ad__inner ad__inner_border_true ad__inner_background_true" style="min-height: 250px; min-width: 300px;">
                    <noscript>
                        <iframe src="https://securepubads.g.doubleclick.net/gampad/adx?iu=/32805352/tx-houston-KHOU-B3351_DesktopTablet/article_atf/news/local&amp;sz=300x250&amp;c=281" width="300" height="250" frameborder="0"></iframe>
                    </noscript>
        </div>
    </div>
                                    </div>
                                </div>
                                <div class="grid__module grid__module_loaded_true">
                                    <div class="grid__module-sizer grid__module-sizer_name_related-videos" data-module-sizer="related-videos" data-count="1">
    <div data-module="related-videos" class="related-videos">
        <div class="related-videos__player">
        <div data-module="video" class="video"
             data-stream="https://video.tegna-media.com/assets/KHOU/videos/d791ad3a-b78b-4d10-8c00-c151d4dee39f/d791ad3a-b78b-4d10-8c00-c151d4dee39f.m3u8"
             data-float="false"
             data-thumbnail="https://media.khou.com/assets/KHOU/images/ca6dd80a-76a0-4e3e-90f0-cccfcd3833c7/ca6dd80a-76a0-4e3e-90f0-cccfcd3833c7_1920x1080.jpg"
             data-title="How the system failed Kendrick Lee, 8-year-old found dead in apartment with siblings"
             data-description="A new report released this week by Child Protective Services details years of investigations leading up to the death of 8-year-old Kendrick Lee."
             data-site="285"
             data-id="d791ad3a-b78b-4d10-8c00-c151d4dee39f"
             data-mute="true"
             data-autoplay="true"
             data-link="https://www.khou.com/video/news/crime/how-the-system-failed-kendrick-lee-8-year-old-found-dead-in-apartment-with-siblings/285-d791ad3a-b78b-4d10-8c00-c151d4dee39f"
             data-origin="video"
             data-section="news"
             data-subsection="crime"
             data-subcategory="crime"
             data-topic=""
             data-subtopic=""
             data-categories="crime,local,news"
             data-captions=""
             data-tracking-tags=""
             data-is-watch-player="false"
             data-is-live-now="VOD"
             data-is-ugc="false"
             data-is-cct="false"
             data-ugc-preroll-disabled="true"
             data-duration=""
             data-disable-preroll-at-duration="0"
             data-disable-preroll="false"
             data-publica-id="9336"
             data-media-tailor-enabled="true"
             data-newscast-preroll-disabled="false"
             data-facebook-app-id="1981419195445082"
             data-sharing-twitter-title="How%20the%20system%20failed%20Kendrick%20Lee,%208-year-old%20found%20dead%20in%20apartment%20with%20siblings"
             data-sharing-twitter-username="KHOU"
             data-a9-pubid="3276">
            <div class="video__ratio-enforcer">
                <div class="video__ratio-enforced">
                    <div class="video__docker-container">
                        <div class="video__docker">
                            <button class="video__docker-close" aria-label="undock video"></button>
                            <div class="video__ratio-enforcer">
                                <div class="video__ratio-enforced">
                                    <div class="video__inner">
                                        <div class="video__player-container">
                                            <div class="video__player"></div>
                                        </div>
                                    </div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
                                            <script type="application/ld+json">
                    {
                    "@context": "http://schema.org",
                    "@type": "VideoObject",
                    "name": "How the system failed Kendrick Lee, 8-year-old found dead in apartment with siblings",
                    "description": "A new report released this week by Child Protective Services details years of investigations leading up to the death of 8-year-old Kendrick Lee.",
                    "thumbnailUrl": "https://media.khou.com/assets/KHOU/images/ca6dd80a-76a0-4e3e-90f0-cccfcd3833c7/ca6dd80a-76a0-4e3e-90f0-cccfcd3833c7_1920x1080.jpg",
                    "uploadDate": "10:19 PM CST February 25, 2022",
                    "duration": "",
                    "contentUrl": "https://www.khou.com/video/news/crime/how-the-system-failed-kendrick-lee-8-year-old-found-dead-in-apartment-with-siblings/285-d791ad3a-b78b-4d10-8c00-c151d4dee39f",
                    "embedUrl": "https://media.khou.com/embeds/video/285-d791ad3a-b78b-4d10-8c00-c151d4dee39f/iframe"
                    }
                        </script>
                </div>
        </div>
        <p class="related-videos__topic">In Other News</p>
        <h4 class="related-videos__title">How the system failed Kendrick Lee, 8-year-old found dead in apartment with siblings</h4>
    </div>
                                    </div>
                                </div>
                        </div>
                    </div>
            </div>
        </div>
        <div class="grid__section grid__section_theme_default" data-theme="default">
            <div class="grid__theme-elements">
                <div class="grid__theme-design-1"></div>
                <div class="grid__theme-design-2"></div>
                <div class="grid__theme-design-3"></div>
                <div class="grid__theme-design-4"></div>
            </div>
            <div class="grid__content grid__content_full-width_false">
                <div class="grid__main grid__main_sticky_none grid__main_full-width_false">
                        <div class="grid__cell grid__cell_columns_3" data-columns="3">
                                <div class="grid__module grid__module_loaded_true">
                                    <div class="grid__module-sizer grid__module-sizer_name_ad" data-module-sizer="ad" data-count="1">
        <div data-module="ad" class="ad ad_position_article_flex_btf ad_background_true"
         data-status="new"
         data-path="/32805352/tx-houston-KHOU-B3351_DesktopTablet/article_flex_btf/news/local"
         data-sizes="[[970,250],[728,90],[1140,286],[1,1]]"
         data-delay="8"
         data-position="article_flex_btf"
         data-refresh-interval="33"
         data-refresh-enabled="true"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id=""
         data-page-type="article">
        <div class="ad__inner ad__inner_border_false ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
                    <noscript>
                        <iframe src="https://securepubads.g.doubleclick.net/gampad/adx?iu=/32805352/tx-houston-KHOU-B3351_DesktopTablet/article_flex_btf/news/local&amp;sz=970x250|728x90|1140x286|1x1&amp;c=282" width="1140" height="286" frameborder="0"></iframe>
                    </noscript>
        </div>
    </div>
                                    </div>
                                </div>
                        </div>
                </div>

            </div>
        </div>
        <div class="grid__section grid__section_theme_default" data-theme="default">
            <div class="grid__theme-elements">
                <div class="grid__theme-design-1"></div>
                <div class="grid__theme-design-2"></div>
                <div class="grid__theme-design-3"></div>
                <div class="grid__theme-design-4"></div>
            </div>
            <div class="grid__content grid__content_full-width_false">
                <div class="grid__main grid__main_sticky_none grid__main_full-width_false">
                        <div class="grid__cell grid__cell_columns_3" data-columns="3">
                                <div class="grid__module grid__module_loaded_true">
                                    <div class="grid__module-sizer grid__module-sizer_name_article-loader" data-module-sizer="article-loader" data-count="1">

<div class="article-loader" data-module="article-loader">
    <button class="article-loader__button"></button>
</div>                                    </div>
                                </div>
                        </div>
                </div>

            </div>
        </div>
    </div>

            </div>
        </main>
            <div class="page__footer page__footer_theme_default">
<footer data-module="footer" class="footer">
    <div class="footer__outer">
        <div class="footer__inner">
            <div class="footer__logo-wrap">
                <img class="footer__logo" alt="KHOU-TV" src="/assets/shared-images/logos/khou.png">
            </div>
            <div class="footer__menu">
                    <ul class="footer__list">
                                <li class="footer__item"><a class="footer__link" href="https://www.khou.com/khoujobs" target="_blank" rel="noopener">Jobs</a></li>
                                <li class="footer__item"><a class="footer__link" href="/terms" target="_self" rel="">Terms of Service</a></li>
                                <li class="footer__item"><a class="footer__link" href="/privacy" target="_self" rel="">Privacy Policy</a></li>
                                <li class="footer__item"><a class="footer__link" href="/adchoices" target="_self" rel="">Ad Choices</a></li>
                    </ul>
                    <ul class="footer__list">
                                <li class="footer__item"><a class="footer__link" href="https://interactive.khou.com/pdfs/PublicFileReport.pdf" target="_blank" rel="noopener">EEO Public File Report</a></li>
                                <li class="footer__item"><a class="footer__link" href="/fcc-public-inspection-file" target="_self" rel="">FCC Online Public Inspection File</a></li>
                                <li class="footer__item"><a class="footer__link" href="/closed-captioning" target="_self" rel="">Closed Caption Procedures</a></li>
                                <li class="footer__item footer__item_visible_false"><a class="footer__link footer__link_behavior_show-consent-options" target="_self" href="/do-not-sell-my-information">Do Not Sell My Personal Information</a></li>
                    </ul>
            </div>
            <div class="footer__copyright">
                &copy; 2022 KHOU-TV. All Rights Reserved.
            </div>
        </div>
    </div>
</footer>            </div>
    </div>
        <div class="page__interstitial">
        <div data-module="ad" class="ad ad_position_exit_interstitial ad_background_true"
         data-status="new"
         data-path="/32805352/tx-houston-KHOU-B3351_DesktopTablet/exit_interstitial/news/local"
         data-sizes="[[1,1]]"
         data-delay="8"
         data-position="exit_interstitial"
         data-refresh-interval="0"
         data-refresh-enabled="false"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id=""
         data-page-type="article">
        <div class="ad__inner ad__inner_border_false ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
        </div>
        <div class="page__notifications">

<div data-module="notifications" class="notifications" style="display:none">
    <div class="notifications__logo-container">
        <img class="notifications__logo" alt="KHOU" src="/assets/shared-images/logos/khou.png" />
    </div>
    <h2 class="notifications__heading">KHOU would like to send you push notifications about the latest news and weather.</h2>
    <p class="notifications__description">Notifications can be turned off anytime in the browser settings.</p>
    <div class="notifications__buttons">
        <button class="notifications__button notifications__button_option_no notifications__button_default_false">No Thanks</button>
        <button class="notifications__button notifications__button_option_yes notifications__button_default_true">Allow</button>
    </div>
</div>
        </div>
        <div class="page__toasts">

<div class="toasts">
    <script class="toasts__toast-template" type="text/template">
        <div class="toasts__toast toasts__toast_new_true">
            <div class="toasts__logo-container">
                <img class="toasts__logo" src="/assets/shared-images/logos/khou.png" />
            </div>
            <div class="toasts__close">×</div>
            <div class="toasts__content">
                <div class="toasts__title"></div>
                <div class="toasts__body"></div>
                <p class="toasts__link">Read More</p>
            </div>
        </div>
    </script>
</div>        </div>
<div class="modal modal_open_false" data-theme="modal">
    <button class="modal__close-button" aria-label="close"></button>
    <div class="modal__content"></div>
</div>    <script src="https://amp.akamaized.net/hosted/1.1/player.esi?apikey=tegna&version=9.1.5"></script>
    <script>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</script>
    <script data-base="/" data-modules="accessibility-statement,ad,adchoices,all-alerts,app-badge,app-promo-link,article,article-loader,article-sharing,article-verify-claim,article-verify-follow-subscribe,breaking-news-alerts,breaking-news-list,carousel,chapter-slider,closings,countdown,datasphere,datasphere-ad-article,datasphere-ad-front,election-single-race,elections,error,footer,from-you,gallery,grid,header,headline-list,hot-races,hot-races-carousel,hourly-graph,iframe,lazy-image,live-broadcasts,live-video-banner,longform,mini-live-video,modal,nbc-olympics-live-streams,nbc-olympics-medals-count,nbc-olympics-tv-schedule,newsletter-signup,notifications,olympics-medal-count,page,personal-info,photo,pollen,privacy,radar-gallery,raw-html,related-stories,related-videos,right-now-hourly,right-now-radar,search,story,story-list,story-row,taboola,toasts,tos,ugc-cta,universal-ad,video,watch-carousel,watch-live,watch-secondary-content,weather-10-day,weather-alerts-list,weather-front-link,weather-hourly,weather-interactive-radar,weather-maps,weather-nav" data-version="6.2.1">!function(){if(window.tegna.supportsJavascript){var e=document.currentScript.dataset.modules.split(","),s=["page","photo","lazy-image","ad","gallery","video","taboola","related-stories","raw-html","elections","election-single-race"];for(var a=document.querySelectorAll("[data-module]"),t=0;t<a.length;++t)n=void 0,function(e,s){for(var a=s.length,t=0;t<a;t++)if(s[t]===e)return 1}(n=a[t].getAttribute("data-module"),s)||s.push(n);var r=document.currentScript.dataset.version,i=document.currentScript.dataset.base,l=document.getElementsByClassName("page")[0]?document.getElementsByClassName("page")[0].dataset.tealiumUrl:"";const o={utils:"tegna-utils_"+r,bem:"bem_"+r,"jquery-utils":"jquery-utils_"+r,storage:"tegna-storage_"+r,common:"common.min_"+r,swiper:"assets/js-libs/swiper/swiper.min","live-messages":"assets/js-libs/live-messages/live-messages",luxon:"assets/js-libs/luxon/luxon.min",tealium:l,signalr:"assets/js-libs/signalr/signalr.min",hls:"https://amp.akamaized.net/players/9.0.13+premier/akamai/amp/core/libs/hls.min",comscore:"assets/js-libs/comscore/comscore.min",places:"//maps.googleapis.com/maps/api/js?key=AIzaSyBEGr3U4E-OGcjwkhiXfqxfuvOqDQ7Z96c&libraries=places","@firebase/app":"firebase-app","@firebase/messaging":"firebase-messaging"};e.forEach(e=>{e in o==!1&&(o[e]=`${e}_${r}`)}),require.config({baseUrl:i,waitSeconds:30,bundles:{common:["page","universal-ad","header","footer","grid","breaking-news-alerts","tegna-utils","tegna-storage","tegna-tracking","header-updater"]},paths:o,shim:{swiper:{exports:"Swiper"},signalr:{exports:"signalR"},tealium:["jquery"]}}),s.forEach(s=>{try{require([s])}catch(e){void 0}})}var n}();
//# sourceMappingURL=configure-require.js.map</script>
        <script data-api-key="AIzaSyBZwI08HurJvcqNwthX4QImmyZaPv8Lcbs" data-project-id="khou-news-app" data-sender-id="199400204667" data-app-id="1:199400204667:web:496a61b5e901214e">!function(){var e,a,i,p,t;window.tegna.supportsJavascript&&(e=document.currentScript.dataset,a=e.apiKey,i=e.projectId,p=e.senderId,t=e.appid,require(["@firebase/app","@firebase/messaging"],function(e){e.initializeApp({apiKey:a,authDomain:`${i}.firebaseapp.com`,databaseURL:`https://${i}.firebaseio.com`,projectId:i,storageBucket:`${i}.appspot.com`,messagingSenderId:p,appId:t}),window.firebase=e}))}();
//# sourceMappingURL=firebase.js.map</script>
    <script>!function(){function e(){void 0;for(var e,t=document.getElementsByTagName("noscript"),n=0;n<t.length;n++){var o=t.item(n);o.outerHTML=(e=o.innerHTML,o=void 0,(o=document.createElement("textarea")).innerHTML=e,0===o.childNodes.length?"":o.childNodes[0].nodeValue)}}var t,n,o;window.tegna.supportsJavascript||(t=document.body,(n=document.createElement("div")).innerHTML='<div style="background-color:#c50000;font-family:sans-serif;color:#ffffff;text-align:center;"><h2 style="margin:0;padding:10px 0;">Your browser is not fully supported.</h2><p style="margin:0;padding: 10px 0;">For full feature support, please upgrade to a modern browser such as <a href="https://www.microsoft.com/en-us/edge" style="color:#ffffff;" target="_blank">Microsoft Edge</a>.</p></div>',t.insertBefore(n,t.firstChild),e(),o=window.setInterval(function(){document.getElementsByTagName("noscript").length?e():clearInterval(o)},500))}();
//# sourceMappingURL=old-browser.js.map</script>
    <script>tegna.performance.parsed = { time: performance.now() };</script>
    <script>window.performance.mark('tegna_dom_parsed');</script>
    <script>window.tegna = window.tegna || {}; window.tegna.loaded = true;</script>
</body>
</html>
